package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w+@\w[.\w]+\.\w+\b`)
var str = `user@mail.com
user@sub.main.top
user@abc
user@
@mail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}