re = /\b\w+@\w[.\w]+\.\w+\b/
str = 'user@mail.com
user@sub.main.top
user@abc
user@
@mail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end