using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\..*-\w{8}$";
string input = @".sfskkkkkkkkkkkkkkkf-1234hh98";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}