$re = '/\..*-\w{8}$/m';
$str = '.sfskkkkkkkkkkkkkkkf-1234hh98';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);