package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\..*-\w{8}$`)
var str = `.sfskkkkkkkkkkkkkkkf-1234hh98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}