#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(\/\/ MARK: -.*\n))(\n.*extension.*{)"
Local $sString = "// MARK: - Bla" & @CRLF & _
"extension Bla" & @CRLF & _
"" & @CRLF & _
"// MARK: - Bla" & @CRLF & _
"private extension Bla {" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"extension Bla {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")