re = /^(?!(\/\/ MARK: -.*\n))(\n.*extension.*{)/m
str = '// MARK: - Bla
extension Bla
// MARK: - Bla
private extension Bla {
extension Bla {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end