$re = '/^(?!(\/\/ MARK: -.*\n))(\n.*extension.*{)/m';
$str = '// MARK: - Bla
extension Bla
// MARK: - Bla
private extension Bla {
extension Bla {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);