const regex = /^\/.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/.*$', 'gm')
const str = `/root/duo/presentations/tools/pages/testing-clone-delete
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components/test
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content/fruitwater.png
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments/frag1
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources/testtest
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}