$re = '/^\/.*$/m';
$str = '/root/duo/presentations/tools/pages/testing-clone-delete
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components/test
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content/fruitwater.png
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments/frag1
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources/testtest
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);