// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/.*$").unwrap();
let string = "/root/duo/presentations/tools/pages/testing-clone-delete
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/components/test
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/content/fruitwater.png
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/fragments/frag1
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/resources/testtest
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox
/root/duo/presentations/tools/pages/testing-clone-delete/test-folder/frag/frag
2/8/23
sheaffer
2
deleted from tree
1035 Tools and Sandbox";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}