package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)submitted by .+ ([a-zA-Z'\-_]+) :`)
var str = `The following records request has been submitted by Bryan Trummer :
The following records request has been submitted by Ray Parker Jr. :
The following records request has been submitted by William Stanley Preston, Esq. :
The following records request has been submitted by Marshall Bruce Mathers III :
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}