re = /submitted by .+ ([a-zA-Z'\-_]+) :/m
str = 'The following records request has been submitted by Bryan Trummer :
The following records request has been submitted by Ray Parker Jr. :
The following records request has been submitted by William Stanley Preston, Esq. :
The following records request has been submitted by Marshall Bruce Mathers III :
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end