import re
regex = re.compile(r"submitted by .+ ([a-zA-Z'\-_]+) :", flags=re.MULTILINE)
test_str = ("The following records request has been submitted by Bryan Trummer :\n"
"The following records request has been submitted by Ray Parker Jr. :\n"
"The following records request has been submitted by William Stanley Preston, Esq. :\n"
"The following records request has been submitted by Marshall Bruce Mathers III :\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")