# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\Q[?]\E
[^[%]*+
(?: \[ (?!\/?\?]) [^[%]* | % (?!empty%) [^{%]* )*+ %empty%
[^[]*+ (?: \[ (?!\/?\?]) [^[]* )*+
\Q[\/?]\E/REPLACED/gx;t' <<< "[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] "