#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)\Q[?]\E" & @CRLF & _
"[^[%]*+ " & @CRLF & _
"(?: \[ (?!/?\?]) [^[%]* | % (?!empty%) [^{%]* )*+ %empty%" & @CRLF & _
"[^[]*+ (?: \[ (?!/?\?]) [^[]* )*+ " & @CRLF & _
"\Q[/?]\E"
Local $sString = "[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text " & @CRLF & _
"[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[?]<h1>%!empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text " & @CRLF & _
"[?][][/<h1>%empty%</h1>][][[[]]]" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>[?]" & @CRLF & _
"[/?] " & @CRLF & _
"text[?]<h1>%!empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] "
Local $sSubst = "REPLACED"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)