$re = '~\Q[?]\E
[^[%]*+
(?: \[ (?!/?\?]) [^[%]* | % (?!empty%) [^{%]* )*+ %empty%
[^[]*+ (?: \[ (?!/?\?]) [^[]* )*+
\Q[/?]\E~x';
$str = '[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] ';
$subst = "REPLACED";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;