import re
regex = re.compile(r"^([^#].*)?^\s*dev1", flags=re.MULTILINE)
test_str = ("#| Environment | Port-prefix | Subnet | Target-host |\n"
"#dev1 300 8 ibdock2\n"
"# dev1 300 8 ibdock2\n"
" #dev1 300 8 ibdock2\n"
" # dev1 300 8 ibdock2\n"
"dev1 300 8 ibdock2\n"
" dev1 300 8 ibdock2\n"
"dev 301 1 ibdock2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")