re = /^([^#].*)?^\s*dev1/m
str = '#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end