package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*([^\s*]+(?: [^\s*]+)*)\*`)
var str = `RegExr was *created by:* gskinner.com, and is *proudly *hosted by *M*edia Temple.
*proudly * or * proudly*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}