$re = '/\*([^\s*]+(?: [^\s*]+)*)\*/m';
$str = 'RegExr was *created by:* gskinner.com, and is *proudly *hosted by *M*edia Temple.
*proudly * or * proudly*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);