re = /\*([^\s*]+(?: [^\s*]+)*)\*/m
str = 'RegExr was *created by:* gskinner.com, and is *proudly *hosted by *M*edia Temple.
*proudly * or * proudly*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end