const regex = /(\d{2}:\d{2}:\d{2})(\d{2}-\d{2}-\d{2})(\w{3}):(\w+?):(\w+?\.\w+?)!.+?,(.+?),(.+?),.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}:\\d{2}:\\d{2})(\\d{2}-\\d{2}-\\d{2})(\\w{3}):(\\w+?):(\\w+?\\.\\w+?)!.+?,(.+?),(.+?),.*', 'g')
const str = `00:16:0808-11-20AES:AE022AGES:022.60032S!20FINI/ID60032S,BLUE01,ZPR008A21308/MR1,2/AFLPLA,KPSM/TD071030,10325053
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}