import re
regex = re.compile(r"(\d{2}:\d{2}:\d{2})(\d{2}-\d{2}-\d{2})(\w{3}):(\w+?):(\w+?\.\w+?)!.+?,(.+?),(.+?),.*")
test_str = ("00:16:0808-11-20AES:AE022AGES:022.60032S!20FINI/ID60032S,BLUE01,ZPR008A21308/MR1,2/AFLPLA,KPSM/TD071030,10325053\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")