#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(")(.*?)(")"
Local $sString = "This text is not a quote. "This is a quote." " & @CRLF & _
"Not a quote." & @CRLF & _
"D. B. says, "My quote is good," but he is not right." & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"In German speaking countries the opening quotation mark is positioned at the bottom („), while the closing quotation mark is at top again (“). The same placement can be found e.g. in Hungary, the Czech Republic, Bulgaria or Russia."
Local $sSubst = "„$2“"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)