import Foundation
let pattern = #"(")(.*?)(")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This text is not a quote. "This is a quote."
Not a quote.
D. B. says, "My quote is good," but he is not right.
---
In German speaking countries the opening quotation mark is positioned at the bottom („), while the closing quotation mark is at top again (“). The same placement can be found e.g. in Hungary, the Czech Republic, Bulgaria or Russia.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"„$2“"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)