# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\")(.*?)(\")"
test_str = ("This text is not a quote. \"This is a quote.\" \n"
"Not a quote.\n"
"D. B. says, \"My quote is good,\" but he is not right.\n\n"
"---\n\n"
"In German speaking countries the opening quotation mark is positioned at the bottom („), while the closing quotation mark is at top again (“). The same placement can be found e.g. in Hungary, the Czech Republic, Bulgaria or Russia.")
subst = "„$2“"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.