#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?=.*[0-9#?!@$%^&*-]) # 1+ digit or special char" & @CRLF & _
"(?=.*[A-Z]) # 1+ uc letters" & @CRLF & _
"(?=.*[a-z]) # 1+ lc letters" & @CRLF & _
"(?=[a-zA-Z0-9#?!@$%^&*-]*$) # all chars valid" & @CRLF & _
"(?!.*(.)\1{2}) # no 3+ repeats" & @CRLF & _
".{8,} # length >= 8 and match string" & @CRLF & _
""
Local $sString = "Test1234!" & @CRLF & _
"Tee123stE" & @CRLF & _
"Teeest123!" & @CRLF & _
"!TESTT1234" & @CRLF & _
"Test1234!~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")