re = /(?=.*[0-9#?!@$%^&*-]) # 1+ digit or special char
(?=.*[A-Z]) # 1+ uc letters
(?=.*[a-z]) # 1+ lc letters
(?=[a-zA-Z0-9#?!@$%^&*-]*$) # all chars valid
(?!.*(.)\1{2}) # no 3+ repeats
.{8,} # length >= 8 and match string
/mx
str = 'Test1234!
Tee123stE
Teeest123!
!TESTT1234
Test1234!~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end