import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[0-9#?!@$%^&*-]) # 1+ digit or special char\n"
+ "(?=.*[A-Z]) # 1+ uc letters\n"
+ "(?=.*[a-z]) # 1+ lc letters\n"
+ "(?=[a-zA-Z0-9#?!@$%^&*-]*$) # all chars valid\n"
+ "(?!.*(.)\\1{2}) # no 3+ repeats\n"
+ ".{8,} # length >= 8 and match string\n";
final String string = "Test1234!\n"
+ "Tee123stE\n"
+ "Teeest123!\n"
+ "!TESTT1234\n"
+ "Test1234!~";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}