using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^C-[0-9]{3}(-C)?$";
string input = @"C-001
C-002C
C-003-C
D-004";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}