$re = '/^C-[0-9]{3}(-C)?$/m';
$str = 'C-001
C-002C
C-003-C
D-004';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);