package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^C-[0-9]{3}(-C)?$`)
var str = `C-001
C-002C
C-003-C
D-004`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}