#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z._]{3,}@[A_Za-z]{3,10}[.]{1}[A-Za-z.]{2,6}"
Local $sString = "vinodthapa@gmail.com" & @CRLF & _
"" & @CRLF & _
"vinod_thapa@gmail.com" & @CRLF & _
"" & @CRLF & _
"vinod.thapa@gmail.com" & @CRLF & _
"" & @CRLF & _
"vinod_t.hapa@gmail.com.us" & @CRLF & _
"" & @CRLF & _
"vinod@fakfkd.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")