// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z._]{3,}@[A_Za-z]{3,10}[.]{1}[A-Za-z.]{2,6}").unwrap();
let string = "vinodthapa@gmail.com
vinod_thapa@gmail.com
vinod.thapa@gmail.com
vinod_t.hapa@gmail.com.us
vinod@fakfkd.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}