re = /[A-Za-z._]{3,}@[A_Za-z]{3,10}[.]{1}[A-Za-z.]{2,6}/m
str = 'vinodthapa@gmail.com
vinod_thapa@gmail.com
vinod.thapa@gmail.com
vinod_t.hapa@gmail.com.us
vinod@fakfkd.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end