const regex = /(?<=\.\d{2}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.\\d{2}).*', 'gm')
const str = `/* Note: input consist digits[0-9] and one dot'.' only, before the match starts. The input on first line and last line are invalid */
2323.34.34.34.34.
45454.454455445
24334.45654565
65.56434ads5/3d56
24...34..4343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}