import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^La.+?no\\s*(?'num_externe'.+?)\\s.*\\s(?:^.*\\n)*.*installation\\s*:\\s*(?'ins_numins'.+?)\\s+.*:\\s*(?'apt_localisation'.+?)\\s+.*:\\s*(?'apt_nom'.+?)\\s+.*:\\s*(?'apt_email'.*?)\\s+Typologie:.*\\s*Motif.+?:\\s*(?'qsy_lib'.+?)\\s*Demande:\\s*(?'commentaire_externe'.+)";
final String string = "Demandes - Date: 03/06/2019 à 09:58 \n"
+ "La demande no 117530 a été externalisée à NORD ENGIE-Cofély, \n"
+ "Site concerné: \n"
+ " - Numéro d'installation : 2870521005 \n"
+ " - Nom du Site : APE ST YRIEIX \n"
+ " Chargé d'affaire: Aurelie GUILLON \n"
+ " Email: \n"
+ " \n"
+ " Typologie: Forfait heures multiservices \n"
+ " Motif détaillé: Demande \n\n"
+ " \n"
+ " Demande: Objet : fixer la boîte à pharmacie petit format au mur. Bonjour, Je sollicite une intervention pour fixer la boîte à pharmacie petit format au mur en zone d'accueil à côté de l'extincteur. Cordialement. Sylvain CLUZEAU.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}