import re
regex = re.compile(r"^La.+?no\s*(?'num_externe'.+?)\s.*\s(?:^.*\n)*.*installation\s*:\s*(?'ins_numins'.+?)\s+.*:\s*(?'apt_localisation'.+?)\s+.*:\s*(?'apt_nom'.+?)\s+.*:\s*(?'apt_email'.*?)\s+Typologie:.*\s*Motif.+?:\s*(?'qsy_lib'.+?)\s*Demande:\s*(?'commentaire_externe'.+)", flags=re.MULTILINE)
test_str = ("Demandes - Date: 03/06/2019 à 09:58 \n"
"La demande no 117530 a été externalisée à NORD ENGIE-Cofély, \n"
"Site concerné: \n"
" - Numéro d'installation : 2870521005 \n"
" - Nom du Site : APE ST YRIEIX \n"
" Chargé d'affaire: Aurelie GUILLON \n"
" Email: \n"
" \n"
" Typologie: Forfait heures multiservices \n"
" Motif détaillé: Demande \n\n"
" \n"
" Demande: Objet : fixer la boîte à pharmacie petit format au mur. Bonjour, Je sollicite une intervention pour fixer la boîte à pharmacie petit format au mur en zone d'accueil à côté de l'extincteur. Cordialement. Sylvain CLUZEAU.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")