use strict;
my $str = 'Demandes - Date: 03/06/2019 à 09:58
La demande no 117530 a été externalisée à NORD ENGIE-Cofély,
Site concerné:
- Numéro d\'installation : 2870521005
- Nom du Site : APE ST YRIEIX
Chargé d\'affaire: Aurelie GUILLON
Email:
Typologie: Forfait heures multiservices
Motif détaillé: Demande
Demande: Objet : fixer la boîte à pharmacie petit format au mur. Bonjour, Je sollicite une intervention pour fixer la boîte à pharmacie petit format au mur en zone d\'accueil à côté de l\'extincteur. Cordialement. Sylvain CLUZEAU.
';
my $regex = qr/^La.+?no\s*(?'num_externe'.+?)\s.*\s(?:^.*\n)*.*installation\s*:\s*(?'ins_numins'.+?)\s+.*:\s*(?'apt_localisation'.+?)\s+.*:\s*(?'apt_nom'.+?)\s+.*:\s*(?'apt_email'.*?)\s+Typologie:.*\s*Motif.+?:\s*(?'qsy_lib'.+?)\s*Demande:\s*(?'commentaire_externe'.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}