# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:height|width):[^;]*;//gm;t' <<< "width:100px;height:200px;float:left;"