re = /(?:height|width):[^;]*;/m
str = 'width:100px;height:200px;float:left;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result