using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-zà-öø-ÿ])[a-zà-öø-ÿ'`]+|[A-ZÀ-ÖØ-Þ][a-zà-öø-ÿ'`]*|[a-zà-öø-ÿ]+'[a-zà-öø-ÿ]*|[a-zà-öø-ÿ]+(?=[_-])|[a-zà-öø-ÿ]+(?=[A-ZÀ-ÖØ-Þ])|\d+";
string input = @"tset
mestTest
Sest-test
zest-ests
best_Tets
Last_etss
LestTset
veryLongCamel
VeryLongCamel
wasn't
wasn`t
Wasn't
Wasn`t
Guárin-Lassous
Guérin-Lassous
Guírin-Lassous
Guórin-Lassous
Guúrin-Lassous
Guârin-Lassous
Guêrin-Lassous
Guîrin-Lassous
Guôrin-Lassous
Guûrin-Lassous
Guürin-Lassous
Guärin-Lassous
Guërin-Lassous
Guïrin-Lassous
Guörin-Lassous
Guürin-Lassous
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}