import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![a-zà-öø-ÿ])[a-zà-öø-ÿ'`]+|[A-ZÀ-ÖØ-Þ][a-zà-öø-ÿ'`]*|[a-zà-öø-ÿ]+'[a-zà-öø-ÿ]*|[a-zà-öø-ÿ]+(?=[_-])|[a-zà-öø-ÿ]+(?=[A-ZÀ-ÖØ-Þ])|\\d+";
final String string = "tset\n"
+ "mestTest\n"
+ "Sest-test\n"
+ "zest-ests\n"
+ "best_Tets\n"
+ "Last_etss\n"
+ "LestTset\n"
+ "veryLongCamel\n"
+ "VeryLongCamel\n"
+ "wasn't\n"
+ "wasn`t\n"
+ "Wasn't\n"
+ "Wasn`t\n"
+ "Guárin-Lassous\n"
+ "Guérin-Lassous\n"
+ "Guírin-Lassous\n"
+ "Guórin-Lassous\n"
+ "Guúrin-Lassous\n"
+ "Guârin-Lassous\n"
+ "Guêrin-Lassous\n"
+ "Guîrin-Lassous\n"
+ "Guôrin-Lassous\n"
+ "Guûrin-Lassous\n"
+ "Guürin-Lassous\n"
+ "Guärin-Lassous\n"
+ "Guërin-Lassous\n"
+ "Guïrin-Lassous\n"
+ "Guörin-Lassous\n"
+ "Guürin-Lassous\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}