$re = '/(?<![a-zà-öø-ÿ])[a-zà-öø-ÿ\'`]+|[A-ZÀ-ÖØ-Þ][a-zà-öø-ÿ\'`]*|[a-zà-öø-ÿ]+\'[a-zà-öø-ÿ]*|[a-zà-öø-ÿ]+(?=[_-])|[a-zà-öø-ÿ]+(?=[A-ZÀ-ÖØ-Þ])|\d+/m';
$str = 'tset
mestTest
Sest-test
zest-ests
best_Tets
Last_etss
LestTset
veryLongCamel
VeryLongCamel
wasn\'t
wasn`t
Wasn\'t
Wasn`t
Guárin-Lassous
Guérin-Lassous
Guírin-Lassous
Guórin-Lassous
Guúrin-Lassous
Guârin-Lassous
Guêrin-Lassous
Guîrin-Lassous
Guôrin-Lassous
Guûrin-Lassous
Guürin-Lassous
Guärin-Lassous
Guërin-Lassous
Guïrin-Lassous
Guörin-Lassous
Guürin-Lassous
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);