use strict;
my $str = 'Love\'s Equal On Earth
In a moving "in" and "out of focus" image, what you see is what you want to believe about yourself.
I love the feeling.
I must confess every day for better feeling
REsTsora is a non-profit website of millions of free books, movies, software, music, websites, and more.
Love\'s Equal. On Earth
';
my $regex = qr/^([^\s]+ ?){1,12}(?<!\.)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}