$re = '/^([^\s]+ ?){1,12}(?<!\.)$/m';
$str = 'Love\'s Equal On Earth
In a moving "in" and "out of focus" image, what you see is what you want to believe about yourself.
I love the feeling.
I must confess every day for better feeling
REsTsora is a non-profit website of millions of free books, movies, software, music, websites, and more.
Love\'s Equal. On Earth
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);