import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{3}[\\/I\\\\\\s\\-\\|]?[A-Z]{3})\\s*(BUY|SELL)+\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*((SL|TP)?\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*(?:(\\(?))((-\\d+|\\d+\\+|\\d+)?\\s*Pips)?(?:\\))?)?\\s*((SL|TP)?\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*(?:(\\(?))((-\\d+|\\d+\\+|\\d+)?\\s*Pips)?(?:\\))?)?\\s*(Intra-Day Trade|SWING TRADE)?\\s*";
final String string = "EURCAD SELL 1.36599\n"
+ "SL 1.37701 (110 Pips)\n"
+ "TP 1.34017 (258 Pips)\n\n"
+ "Intra-Day Trade";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}