const regex = new RegExp('([A-Z]{3}[\\/I\\\\\\s\\-\\|]?[A-Z]{3})\\s*(BUY|SELL)+\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*((SL|TP)?\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*(?:(\\(?))((-\\d+|\\d+\\+|\\d+)?\\s*Pips)?(?:\\))?)?\\s*((SL|TP)?\\s*(-\\d+\\.\\d+|\\d+\\.\\d+\\+|\\d+\\.\\d+)?\\s*(?:(\\(?))((-\\d+|\\d+\\+|\\d+)?\\s*Pips)?(?:\\))?)?\\s*(Intra-Day Trade|SWING TRADE)?\\s*', 'gm')
const str = `EURCAD SELL 1.36599
SL 1.37701 (110 Pips)
TP 1.34017 (258 Pips)
Intra-Day Trade`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}