$re = '/([A-Z]{3}[\/I\\\\\s\-\|]?[A-Z]{3})\s*(BUY|SELL)+\s*(-\d+\.\d+|\d+\.\d+\+|\d+\.\d+)?\s*((SL|TP)?\s*(-\d+\.\d+|\d+\.\d+\+|\d+\.\d+)?\s*(?:(\(?))((-\d+|\d+\+|\d+)?\s*Pips)?(?:\))?)?\s*((SL|TP)?\s*(-\d+\.\d+|\d+\.\d+\+|\d+\.\d+)?\s*(?:(\(?))((-\d+|\d+\+|\d+)?\s*Pips)?(?:\))?)?\s*(Intra-Day Trade|SWING TRADE)?\s*/m';
$str = 'EURCAD SELL 1.36599
SL 1.37701 (110 Pips)
TP 1.34017 (258 Pips)
Intra-Day Trade';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);